Results 1 to 4 of 4

Thread: M20 5000 RPM Hiccup

                  
   
  1. #1
    Senior Member Scotty's Avatar
    Join Date
    May 2006
    Location
    North Potomac, MD
    Posts
    196

    Question M20 5000 RPM Hiccup

    I posted this thread on bimmerforums regarding engine cut-out at 5000 RPM under hard acceleration. If anybody has a clue as to what's going on, I'd love to hear it.

    Thanks!
    Scott Lowrey

  2. #2
    Senior Member Scotty's Avatar
    Join Date
    May 2006
    Location
    North Potomac, MD
    Posts
    196
    For those that don't frequent bimmerforums, I appear to have a bad throttle position sensor. Looking forward to happy romps to redline without any whiplash. Stay tuned...
    Scott Lowrey

  3. #3
    Senior Member
    Join Date
    Mar 2005
    Location
    Ft. Belvoir
    Posts
    363
    I had this issue also. I took the T body off the car and made sure it was in tolerances.

    It was fine after that on my 89 that has gone away.

  4. #4
    Senior Member Scotty's Avatar
    Join Date
    May 2006
    Location
    North Potomac, MD
    Posts
    196
    Wow, long time. I have an update. After swapping parts like an idiot (well, nothing wrong with replacing old parts on an old car, I guess), I finally fixed the problem.

    It was the Air Flow Meter.

    Yes, the TPS was bad, but that wasn't causing the dead spot. I paid $45 for a used AFM on eBay and - presto! The car runs great.

    For those of you who have been kind enough to instruct me at the driver's schools, I hope I haven't caused any neck injuries. It should be smooth sailing from now on!
    Scott Lowrey

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •