Results 1 to 10 of 10

Thread: SMG locked up

                  
   
  1. #1

    SMG locked up

    Hey, I'm new to posting, but before I pay to get my 2002 M3 SMG towed to the service station (in shame), I wanted to see if anyone has had this problem before: I went to start the car, but the SMG display showed that it was still in Reverse instead of Neutral (where the shifter was). Since SMGs won't start in gear, I haven't been able to get the car to start all day. I've tried disconnecting the battery, and leaving it alone for awhile, no dice. Does anyone know of a system reset switch or some other way to get the car in neutral.

    Thanks,
    Matt

  2. #2
    Senior Member SMOODY's Avatar
    Join Date
    Nov 2004
    Location
    Golden, CO
    Posts
    277
    Not sure if there is a simple fix for this one. I know that there have been issues with solenoids and software in the SMGs. I have also seen stories online about folks having similar problems that required the SMG control units to be swapped for an updated version.

    Your best course of action is probably to have it towed to the dealer, bitch heavily, and hope that they will fix it for free.

    Edit: I just remembered one possible quick fix. Some of the cars have had issues with a flaky hood sensor. Basically the car thinks that the hood is open, so the SMG will not go into gear. The fix is to open and forcefully close the hood. I know this is not quite the same issue you are having, but it might be worth a try.
    Last edited by SMOODY; 09-18-2006 at 05:01 PM. Reason: More info.
    2001 330i (my car)
    2004 Audi Allroad (wife's car and family truckster)

  3. #3
    Senior Member tgmeyer's Avatar
    Join Date
    May 2005
    Location
    Montgomery Village, MD
    Posts
    131
    Rut Roh!
    Please tell me this in an anomaly. I have a 2005 330CiC w/ SMG.
    Tom
    "Everyone should believe in something. I believe I'll go fishing."
    --Thoreau--
    2005 330 CiC

  4. #4
    Senior Member
    Join Date
    Jul 2004
    Location
    Bethesda, MD
    Posts
    659
    Replace the SMG relay.

    And check your battery.

    If those don't do it, you're probably ****ed.
    2006 GMC Sierra 2500HD 4WD Duramax LBZ/Allison 6-speed
    2002 BMW M3 - Alpinweiss III/Black
    1999 323i KP/GTS2 - Alpinweiss III (Black Hood, other stuff)
    1990 325is - Brilliantrot/Tan
    1989 325is - Alpinweiss II/Black (S50B32)
    1989 M3 - Alpinweiss II/Black (S62B50 in progress)



  5. #5
    Senior Member bren's Avatar
    Join Date
    Jun 2004
    Location
    Timonium
    Posts
    226
    Sometimes mine needs a really HARD press on the brake pedal with the ignition on.

  6. #6
    Member
    Join Date
    May 2006
    Location
    Northern VA
    Posts
    32
    Quote Originally Posted by tgmeyer View Post
    Rut Roh!
    Please tell me this in an anomaly. I have a 2005 330CiC w/ SMG.
    Tom
    Totally different SMG.

  7. #7
    Thanks for everyone who offered some help. I called a BMW mechanic that I know and he had me disconnect the battery, leave the car alone overnight, and try starting it in the morning. The next morning the car started right up. I guess this sort of thing has a tendency to happen when the car is turned off in Reverse instead of in 1st gear. I can't find anything in the manuals that says that this can happen, but I'm definately not going to do it again. Just a heads up to everyone.

  8. #8
    Senior Member jkuper's Avatar
    Join Date
    Jun 2004
    Location
    MD
    Posts
    264
    I never had issues leaving it in reverse. 2 years and 20k miles. I'd say it was left in reverse 90% of the time. :dunno


    -- Jason

  9. #9
    Senior Member tgmeyer's Avatar
    Join Date
    May 2005
    Location
    Montgomery Village, MD
    Posts
    131
    Quote Originally Posted by Slpnbyu View Post
    Totally different SMG.
    Yes, I realize that but....
    "Everyone should believe in something. I believe I'll go fishing."
    --Thoreau--
    2005 330 CiC

  10. #10
    Senior Member
    Join Date
    Jul 2004
    Location
    Bethesda, MD
    Posts
    659
    If that's the case replace the SMG relay - You've gotten a reprieve, but it's almost certainly failing. It's a $5 part and it's easy to do.
    2006 GMC Sierra 2500HD 4WD Duramax LBZ/Allison 6-speed
    2002 BMW M3 - Alpinweiss III/Black
    1999 323i KP/GTS2 - Alpinweiss III (Black Hood, other stuff)
    1990 325is - Brilliantrot/Tan
    1989 325is - Alpinweiss II/Black (S50B32)
    1989 M3 - Alpinweiss II/Black (S62B50 in progress)



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •