PDA

View Full Version : S54 Leaking oil



Zcruizer
06-09-2009, 06:52 PM
Hey guys, I have a 2001 S54 motor with 45,000 miles on it dropping oil on the driveway after warmed up. It doesn't seem to be coming from the oil pan gasket but a little higher up and near/behind the A/C compressor (can't yet say weather or not the fan is blowing the oil up in there. I haven't yet started taking anything off to verify origin, I thought I would jump on to see if anyone has an immediate clue. Any suggestions/history lessons would be appreciated.

1996 328ti
06-09-2009, 07:18 PM
I don't know how different these are from a M52/S52 but I had a leaky oil filter housing.
Oil leaks from the plugs in the housing. I think on some housings you can replace the plugs. Check around the VANOS oil hose too.

Reach
06-09-2009, 08:20 PM
Judging by your description, my personal experience seeing it (not on my car thankfully) and numerous reports of it on M3Forum... I'm going to guess a seal failure at your constant pressure valve. This relief valve is on the passenger side of your block, basically just under the rear header and is pretty hard to get to unless you've got your car on a lift. Even then its no trick.

It is #10 on this diagram (http://www.realoem.com/bmw/showparts.do?model=BL93&mospid=47714&btnr=11_2988&hg=11&fg=10) and your likely culprit. The valve itself is fine but it has an integrated rubber o-ring which is known to deform and allow a slow oil leak. The fix is to replace the part as a separate seal is unavailable.

Here is an example thread on it: http://www.m3forum.net/m3forum/showthread.php?t=217320

And here are some pics for location and visual reference on an S54 outside of a chassis.
http://www.jdmchat.com/daniel/cpv01.jpg
http://www.jdmchat.com/daniel/cpv02.jpg

Zcruizer
06-10-2009, 04:55 PM
Thanks for the tips, Thursday morning I'll be out there looking deeper. I hope it's not the pressure valve, actually I hope it's just a bad dream and it's chocolate syrup on the drive and little angels are dancing and laughing. Gotta stop eating those wacky mushrooms. :biggrin:
I'll post what I see, thanks again.

Nick325xiT 5spd
06-11-2009, 09:22 PM
You want it to be the CPV. It's accessible without any significant disassembly for low cost if you DIY.

Zcruizer
06-11-2009, 09:36 PM
Well, you won't believe what the problem was. I didn't get to start looking in depth until this evening. It took me a while to figure this out because I cleaned the car up and took it for a drive to see fresh oil. After it cooled a bit I noticed loose oil pan bolts. Four to be exact. Two were very loose and two where half of that. I was very happy, in a way, that was all. One little setback though, I sheared one of the bolts in half. Oops, a bit more than 10nm I think. Friday I'm off to fix my next issue.
Any tips on that......?!?!:icon_cens

1996 328ti
06-13-2009, 06:36 AM
Drill it out with an EZout.

Zcruizer
06-13-2009, 07:12 AM
Thanks for the help. I've got the bolt out and replaced. No more oil on the ground, yippie !!

Reach
06-13-2009, 03:37 PM
Congrats on a successful diagnosis and fix!